Перейти к содержанию

Использование НЕ в названии переменной/функции

Не рекомендуется использовать отрицание в названиях функций или переменных. Подобное наименование может приводить к плохо читаемому и плохо понимаемому коду.

Не очень корректный код

Функция ЗначениеНеЗаполнено() //ошибка
    ...
КонецФункции

Если Не ЗначениеНеЗаполнено() Тогда

КонецЕсли;

Более корректный код

Выражение = Не ОбратноеУсловие;

Пока Не ОбратноеУсловие() Цикл

КонецЦикла;

См. также - Правило Функция или булева переменная всегда используется с Не