Перейти к содержанию

Метод недоступный в веб-клиенте

При разработке современных конфигураций на управляемых формах, необходимо учитывать возможную работу в веб-клиенте. Для этого стоит обращать внимание на доступность методов глобального контекста. Перечень доступных контекстов перечислен в синтакс-помощнике. Так например метод ВвестиЧислодоступен в контексте тонкого клиента, но недоступен в веб-клиенте. Соответственно, при вызове такого метода на веб-клиенте будет сгенерировано исключение времени выполнения.

Особенности реализации: Проверка пропускает выражения находящиеся в блоке условных инструкций препроцессора. Например:

Процедура Тест()
    #Если НЕ ВебКлиент Тогда
        Количество = 1;
        Если ВвестиЧисло(Количество, "Введите количество", 10, 2) Тогда // нет ошибки
        КонецЕсли;  
    #КонецЕсли
КонецПроцедуры

Так как метод ВвестиЧисло находится внутри инструкции препроцессора, он исключается из проверки.