Перейти к содержанию

Подозрительное продолжение цикла

Код внутри цикла должен быть легко читаем и понятен. Не следует усложнять код лишними условиями, особенно для случаев продолжения или прерывания цикла. Например, не нужно добавлять оператор Продолжить, если цикл в любом случае будет продолжен.

Подозрительный код

Пока Условие1 Цикл
    ВызовМетода(1, "какой-то текст");
    Если Условие2 Тогда // сложно
        Продолжить; 
    Иначе
        КакойТоКод();
    КонецЕсли;
КонецЦикла;

Исправленный код - инверсия условия

Пока Условие1 Цикл
    ВызовМетода(1, "какой-то текст");
    Если Не Условие2 Тогда
        КакойТоКод(); 
    КонецЕсли;
КонецЦикла;

См.также - Jump statements should not be redundant