Перейти к содержанию

Одинаковые условия в последовательности вида "Если (....) ИначеЕсли (....) ИначеЕсли (....)".

Дублируются условия в разных ветках оператора Если.

Часто это является последствиями неверного или незаконченного "копипаста", т.е. при дублировании кода.

Эти дублирующиеся условия могут приводить к проблемам производительности, т.к. возможно повторное вычисление значений, в т.ч. и сложных, тяжелых - обращение к БД, чтение файлов и т.п.

Рекомендация - проверьте код на валидность условий. Возможно, есть смысл исправить дублирование условий, переписав или упростив код.

Примеры подозрительных условий

Если Перем1 = Перем2 Тогда
    А = 1;
ИначеЕсли Перем2 = Перем1 Тогда
    Б = 1;
КонецЕсли;
Если УсловиеВыполнено() Тогда
    А = 1;
ИначеЕсли Функция2(Значение1, Значение2) Тогда // ошибка
    Б = 1;
ИначеЕсли Функция2(Значение1, Значение2) Тогда // ошибка
    В = 1;
КонецЕсли;

или более сложный вариант дублирования

Если ПервоеУсловиеВыполнено() Тогда
    А = 1;
ИначеЕсли Перем1 = Перем2 Тогда // ошибка
    Б = 1;
ИначеЕсли ТретьеУсловиеВыполнено() Тогда
    В = 1;
ИначеЕсли Перем1 = Перем2 Тогда // ошибка
    Г = 1;
КонецЕсли;

Согласно Common Weakness Enumeration потенциальные ошибки, найденные с помощью этой диагностики, классифицируются как - CWE-570 - CWE-571

См. также - Правило Одинаковые условия в последовательности вида "Если (....) ИначеЕсли (....) ИначеЕсли (....)". - Правило Дублирование одинаковых/похожих блоков кода - Правило Совпадающие/одинаковые тела методов - MSC12-C. Detect and remove code that has no effect or is never executed - MITRE, CWE-489 - Leftover Debug Code - MITRE, CWE-570 - Expression is Always False - MITRE, CWE-571 - Expression is Always True - MISRA C:2004, 13.7 - Boolean operations whose results are invariant shall not be permitted. - MISRA C:2012, 14.3 - Controlling expressions shall not be invariant