Перейти к содержанию

Блоки кода не должны быть "закомментированы"

Программные модули не должны иметь закомментированных фрагментов кода, а также фрагментов, которые каким-либо образом связаны с процессом разработки (отладочный код, служебные отметки) и с конкретными разработчиками этого кода. Например, недопустимо оставлять подобные фрагменты в коде после завершения отладки или рефакторинга:

Процедура ПередУдалением(Отказ)
    // Если Истина Тогда
    //     Сообщение("Для отладки");
    // КонецЕсли;
КонецПроцедуры

также неправильно:

Процедура ПередУдалением(Отказ)
    Если Истина Тогда
        // Иванов: доделать 
    КонецЕсли;
КонецПроцедуры

Правильно: после завершения отладки или рефакторинга удалить обработчик ПередУдалением из кода.