Перейти к содержанию

Сложные условия

Плохо читаемые или сложные условия нужно выделять в переменные или методы.

"Тяжелые" условия затрудняют понимание кода.

Подозрительный код

Если Тип = "Структура"
    ИЛИ Тип = "Строка"
    ИЛИ Тип = "Число" Тогда
  КакойТоКод();
КонецЕсли;

Исправленный код

Если ПодходящийТип(Тип) Тогда
    КакойТоКод();
КонецЕсли;

Функция ПодходящийТип(Тип)
  Возврат Тип = "Структура"
    ИЛИ Тип = "Строка"
    ИЛИ Тип = "Число";
КонецФункции